FSFX Packages - Q400 Immersion Updated for P3D v4

23157144_698271957042151_337010467227168678_o.jpg

FSFX Packages released a statement earlier today on their facebook page, stating that their Q400 Immersion Package is now compatible with Prepar3D v4 along with the above image. In order to get this update, you simply have to update the package on VFXCentral. The upgrade is Completely Free! If you haven't already purchased this amazing addition to the beautiful Q400, you can buy it here from the FSFX Website!

Majestic Q400

This product is ONLY compatible with the Majestic Q400, and this must be purchased separately. In order for the immersion effects to work in P3D v4, you MUST purchase the Majestic Q400 64-bit edition, which requires a $20 upgrade fee if you previously purchased the 32-bit edition. You can purchase the Majestic Q400 x64 Pilot, x64 Pro, x86 Pilot, or x86 Pro from SimMarket.